Adobe Reader And Adobe Flash Security Updates

On Monday, March 21st, Adobe issued updates for Adobe Reader and Adobe Flash Player to fix multiple security vulnerabilities. These updated versions are recommended for all previous versions of Adobe Reader and Adobe Flash Player on both Windows and Mac OS.

ISC strongly suggests that all users of Adobe Reader 9.x update to version 9.4.3 as soon as possible. Adobe Acrobat Pro 9 users should also update to version 9.4.3.

ISC strongly suggests that all users of Adobe Reader X update to version 10.0.2 as soon as possible. Adobe Acrobat Pro X users should also update to version 10.0.2.

ISC strongly suggests that all users of Adobe Flash Player update to version 10.2.153.1 as soon as possible.


References

Adobe's security bulletin on these vulnerabilities is located here:

http://www.adobe.com/support/security/advisories/apsa11-01.html

The direct download link for Adobe Reader 9.4 (which must then be updated to 9.4.3) is located here:

http://get.adobe.com/reader/otherversions/

The direct download link for Adobe Reader X 10.0.1 (which must then be updated to 10.0.2) is located here:

http://get.adobe.com/reader/?no_ab=1

The direct download link for Adobe Flash Player 10.2.153.1 is located here:
http://get.adobe.com/flashplayer/otherversions/

The Supported Products and Supported Products for Providers pages for Adobe Reader and Adobe Flash Player have related information at:

http://www.upenn.edu/computing/product/specs/adobereader.html

http://www.upenn.edu/computing/provider/product/specs/adobereaderprovider.html

http://www.upenn.edu/computing/product/specs/flashplayer.html

http://www.upenn.edu/computing/provider/product/specs/flashplayerprovider.html