Courses inTouch: "Invalid Browser" error

Iif you're trying to use the most recent version of Internet Explorer (version 10) to get to Courses inTouch, you'll get an error message that you're using an "invalid browser."  Use Firefox, Google Chrome, or Safari instead and you'll be able to get to Courses inTouch.  You may need to copy and paste the web address:

http://www.upenn.edu/isc/apps/CoursesInTouch/